
Click Add to add the entered URL, user id, and password to the Password List.



If you check this the domains of any new URL's you add to the GAS file will be placed in
the Include section of the filter.    This tells Grab-a-Site that you only want to grab pages 
that reside at the domain of the URL's you add.    For example:    If you checked this, 
added the URL http://www.bluesquirrel.com and started grabbing, only pages from 
www.bluesquirrel.com would be grabbed even though there might have been links to 
other domains such as www.yahoo.com, www.lycos.com, etc.



Click Browse to find your Browser on your hard drive.



Setting the path to your Browser allows Grab-a-Site to run your browser when 
necessary to view pages.



Click Cancel to reject any changes you might have made.



Command Line Options
Using command line options, Grab-a-Site can be run entirely unattended.    For example
entering the line,

grabsite soccer /a:http://www.soccer.com /u /e

will:

1.    create the SOCCER.GAS file (or open it if it already exists),

2.    add the http://www.soccer.com URL to the SOCCER.GAS file

3.    start grabbing unattended, and

4.    exit Grab-a-Site when done.

Below are explanations of each available command line option:

File Name

Entering a file name after the GRABSITE command opens the existing GAS file if it exists.    If it 
does not exist, the file is created.    If no file name extension is used, .GAS is added.

/A:<URL>

Adds that URL to the .GAS file (new or existing)

/U

Starts grabbing unattended.

/I:<HTML file> | <text file>

Imports all of the URL's in the HTML file into the .GAS file taking into account the /C parameter 
which will Auto Constrain the .GAS file to that domain (puts an Include entry into the Filter).    
Detects whether it is a text file or an HTML file by looking for ‘<’ in the first 80 characters.

/L<Number of Levels>

Number of levels to crawl when grabbing.    Will default to 1 level, /L without a number defaults 
to infinite levels.

/K<bytes>

Number of K to crawl before quitting.    Defaults to an infinite amount.    /K without a number will 
set the file to an infinite amount



/T<minutes>

Sets the number of minutes that the crawler will crawl.    Default is infinite.    /T without a number 
will set the file to infinite time

/O<Number of objects>

Sets the number of objects to get (includes pages and images).    Default is infinite.    /O without 
a number will set the number of documents to infinite.

/D:<directory>

Sets the output directory for the .GAS file.    In the absence of a directory, it will default to the 
location of the .GAS file + OUTPUT<number> (01, 02.. 99)

/C[<0>]

Turns Add domains of new URL's to Include Filter on or off.    /C0 turn it off.    /C or /C1 turns 
it on.

/E

Exits Grab-a-Site when through grabbing
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Click Default to make the highlighted URL, along with its user id and password, the 
default password.    See default password under Edit-Options for more information.



The Default Password is used whenever a web page requests a password and you 
have not specified a password for that specific web page in Passwords under Edit-
Preferences.    You must enter a user id and the corresponding password.



Your E-mail Address is used to let a server know who has just crawled through.



Edit
The Edit menu allows you to Undo your last action, Cut, Copy, or Paste, Add, Edit, or 
Remove URL's.    You can also edit the Preferences and Options for Grab-a-Site.



Click Edit to edit the highlighted URL and its user id and password.



Edit-Add URL...
Clicking Add URL... under the Edit menu allows you to add another URL from where to 
start grabbing Web pages. 



Edit-Copy
Clicking Copy under the Edit menu places a copy of the highlighted URL onto the 
clipboard to be pasted elsewhere.



Edit-Cut
Clicking Cut under the Edit menu cuts the highlighted URL from Grab-a-Site and places 
it on the clipboard to be pasted elsewhere.



Edit-Edit URL...
Clicking Edit URL... under the Edit menu allows you to edit a highlighted URL which 
may have changed or be incorrect.



Edit-Options...
Clicking Options under the Edit menu allows you to set some general options for Grab-
a-Site.
Click on the dialog box below to learn more about each option:



Edit-Paste
Clicking Paster under the Edit menu pastes the text (URL) from the clipboard to Grab-a-
Site.



Edit-Preferences...
You can click Preferences... under the Edit menu to indicate your preferences while 
running Grab-a-Site.
Click on the dialog box below to learn what each option is:



Edit-Remove URL...
Clicking Remove URL... under the Edit menu allows you to Remove a URL from the list 
of URL's to be grabbed.



Edit-Undo
Click Undo under the Edit menu to reverse your last action.    This is useful if you feel 
you have made a mistake.



The Exclude section lists all the items which will not be grabbed even if the same item is
listed in the Include section.



File
From the File menu you can create New .GAS files or Open existing .GAS files.    You 
can also Import URL's from text or HTML files or Exit the program.



File-Exit
Click Exit under the File menu to exit the Grab-a-Site program.



File-Import
You can import all the URL's from an HTML page (bookmark list) or from a text file.    
The text file should be nothing but a list of URL's for the import to work properly.

Highlight the file you wish to import and click Open.



File-New 
Enter the name of the GAS file you want to create.
Click Open or Save to save it.
Click Cancel to not create a new GAS file.



File-Open
Highlight the GAS file you want to open.
Click Open to open the GAS file.
Click Cancel to not open a GAS file.



Filter
The Include/Exclude Filter allows you to determine what is to be grabbed and what is 
not to be grabbed.
Click on the dialog box below to learn more about each section:



Find information within the Web site I have downloaded
By using the Microsoft Windows 95 Find on the directory that you have grabbed, you 
can find text strings in the grabbed HTML documents.

Follow these steps to run Find:

1.    Click on Start
2.    Click on Find
3.    Click on "Files or Folders..."
4.    Set "Look in:" to the directory where you grabbed the files
5.    Click on the Advanced tab and in the "Containing text: field, enter the text you are 
looking for.
6.    Click the Find Now button.



How do I get technical support?
To contact technical support for any reason, E-mail support@bluesquirrel.com.    You 
can also purchase telephone support at the Blue Squirrel Store located on the World 
Wide Web at http://www.bluesquirrel.com.



Clicking the green dot for GO means start grabbing now.



Grab
Use the Grab menu to start or stop grabbing.



Grab a password protected site
To grab a password protected site, you need to:

1.    Have a valid user id and password for the site.
2.    Enter the user id and password for that particular site using the Password List from 
Edit-Preferences, or
Enter the user id and password in the Default Password fields under Edit-Options.
3.    Grab the site!



How Do I Grab a Site?
To grab a site follow these steps:

1.    Create a GAS file using New under the File menu
2.    Add URL's using the Edit menu.
These URL's are those you wish to grab first.
3.    Edit the GAS preferences
4.    Select start under the Grab menu
When Grab-a-Site is finished grabbing, the Table of Contents will be displayed in your 
Browser.    Click on the URL's in your browser to start browsing off-line.



Grab a site including files that are on FTP links
To grab a site including files that are on FTP links follow these steps:

1.    Create a GAS file using New under the File menu
2.    Add URL's using the Edit menu.
These URL's are those you wish to grab first.
3.    Edit the GAS preferences
4.    Make sure to check Retrieve FTP links on the preferences dialog box.
5.    Select start under the Grab menu
When Grab-a-Site is finished grabbing, the Table of Contents will be displayed in your 
Browser.    Click on the URL's in your browser to start browsing off-line.



You can set the HTTP Proxy and Port when using a proxy or gateway for access to the 
Internet.



Help
Select the Help menu for the Index of Grab-a-Site's on-line documentation or 
information about Grab-a-Site.



Help-About Grab-a-Site
Clicking About Grab-a-Site under the Help menu displays information regarding the 
version of Grab-a-Site you are using and its registration status.



Help-Index
Clicking Index on the Help menu opens a Windows Help file containing the on-line 
Grab-a-Site documentation.



How Do I...
Grab a site?
Grab a password protected site?
Grab a site including files (.EXE or .ZIP) that are on FTP links?
Get technical support?
Find information within the Web site I have downloaded?
Use the filter?



Anything which includes text from the Include section will be grabbed.



Launch Blue Squirrel Home Page
Clicking the Blue Squirrel opens the Blue Squirrel Home Page on the World Wide Web 
using your Browser.



Checking Maximum amount of time to collect allows you to dictate how long Grab-a-
Site should grab in hours and minutes.



Checking Maximum bytes to collect (in Kilobytes) allows you to cap the cumulative 
size of the grabbed pages.



Checking Maximum number of documents to collect allows you to determine how 
much information you want to download.



Checking this and entering the Maximum number of levels to crawl allows you to 
indicate how many levels of hypertext links form one page to the next Grab-a-Site 
should follow.    Leaving this unchecked indicates an infinite number of levels to be 
grabbed.



Menus Commands
File
Edit
Grab
View
Help
Register!



The Number of Retries before moving on to next level field allows you to determine 
how many times to try to get a document before moving on.



Click OK to accept your changes.



Overview of Grab-a-Site
Tired of waiting for slow servers to return the page you want to browse?    Sick of 
watching images appear line-by-line as they come across your slow modem?    You 
need Grab-a-Site!

Worried about the kinds of information your children, students, or employees are 
browsing on the Internet?    You need Grab-a-Site!

Grab-a-Site downloads complete portions of the World Wide Web for you to browse on 
your hard drive.    You give Grab-a-Site a Web page's URL or a list of URL's and it will 
follow as many links from those pages as you specify.    All the pages that Grab-a-Site 
crawls are downloaded to your hard drive.    The links and graphics come with them.    
You can then browse through the pages as if you were on the Internet.    No more 
waiting for pages to download!    No more waiting for images to come across the phone 
line!    You can give your children, students, and employees access to Web pages 
without giving them access to the entire Web!

Grab Away!



Password
From the Preferences dialog box, the Passwords dialog box allows you to enter specific 
passwords for specific password protected sites.    Note:    Grab-a-Site does not push 
buttons to submit forms.
To learn more about each section in the dialog box below, please click on the section.



The Password List shows all the URL's for which you have passwords entered.



Enter the password for the password protected web page.



Register
Click Register to register your software with Blue Squirrel.    This allows us to inform you
regarding Grab-a-Site upgrades and future Blue Squirrel products.



Click Remove to remove the highlighted URL, along with its user id and password, from 
the Password List.



Check this box to have Grab-a-Site follow FTP links as well as HTTP links.



Checking Retrieve inline images informs Grab-a-Site that you wish all graphics from 
the Web pages to be downloaded also.



In the Run After field you can indicate which program/file should be launched when 
Grab-a-Site is finished grabbing.    The default is to open the Table of Contents file 
created for use with the just grabbed GAS file.



The Static section allows you to Add, Edit, and Remove domains to or from the Include 
and Exclude sections.



Status bar
The Status bar at the bottom of the screen lets you know what is happening and in what
directory you are working.



Clicking the Red square for Stop means stop grabbing now.



Technical Support
For free technical support, send E-mail to support@bluesquirrel.com.    To purchase 
other forms of technical support, visit the Blue Squirrel web site at 
http://www.bluesquirrel.com or call us at (801) 484-2225.



The Timeout on Connect (# of seconds) field allows you to determine how long to 
wait for slow connections.



Toolbar
The Toolbar allows you to quickly perform some common actions.    Click on the Toolbar 
below to see what each button does.



You enter the URL here for which you need and have a password.



Checking this box will maintain the directory structure of the site you grab.



If you check this box, Grab-a-Site will create a directory for the domain to store 
everything you grab from that domain.



Check Use Filter if you want to use the filter to include or exclude certain objects from 
your grab.



Check this box to truncate file names to 8 characters in length.



Use the Filter
To show you how to use the Grab-a-Site Filter, we have included two examples:

How do I grab everything on www.microsoft.com/windows except the files in the 
windows/download directory?
1.    Add www.microsoft.com/windows to the Include section of the Filter
2.    Add www.microsoft.com/windows/download/ to the Exclude section of the filter
3.    Go Grab!

How do I grab everything on www.windows95.com and all of the .exe's and .zip's that it 
points to
1.    Add www.windows95.com to the Include section of the Filter
2.    Add .exe to the Include section of the Filter
3.    Add .zip to the Include section of the Filter
4.    Go Grab!



Enter the User ID you have for the password protected Web page.



View
From the View menu you can hide or display the Toolbar and the Status bar.    You can 
also view the Table of Contents, a URL, or the Blue Squirrel Home Page.



View-Table of Contents
Viewing the Table of Contents allows you to start browsing through the grabbed pages 
of a GAS file.    The Table of Contents contains all the URL's you added to the GAS file 
before grabbing.



View-URL
Clicking URL under the View menu allows you to view a single URL in your browser.    
You may want to make sure it still is functional and should still be included in your GAS 
file.






